Please include your version of Joomla, Moodle and Joomdle when seeking assistance.  Also, if you do not get an immediate response, do not bump your posting as it will be deleted.


Remember Joomdle is a free extension and the Joomdle Team has 'day time' jobs as well.

Thanks for your understanding

Bienvenido, Invitado
Username: Password: Recordarme
  • Página:
  • 1

TEMA: Joomdle web service Received empty response from Moodle

Joomdle web service Received empty response from Moodle 1 year 9 months ago #1

I installed joomdale on my joomla 2.5.7 and moodle 2.3 and after following the installation procedure on the wiki i got the error "Received empty response from Moodle" when i run system check, have checked the moodle url that it includes http:// also have disabled firewall and still i cant get through the error, Can you please kindly assist i am keen to work of the joomdle paltform.
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 1 year 9 months ago #2

  • Chris
  • Chris's Avatar
  • DESCONECTADO
  • Karma: 29
Having the // in front is only one of the common errors. You must have the exact url entered in Joomdle for Joomla and Joomdle for Moodle. What have you entered in both locations?

Also, there are a few other potential things that have been highlighted in this forum depending on your environment. Have you searched for this error message?
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 1 year 8 months ago #3

  • Nick
  • Nick's Avatar
  • DESCONECTADO
  • Karma: 0
Hi Chris,
interestingly, it seems there might be a valid variation of URL paths config to be added here.
I have installed moodle in a subdirectory of my joomla site. (www.mydomain/moodle)
After many attempts at solving the health check error messages I eventually got it "all green" by entering the following paths:
Joomdle auth path (moodle): h ttp://mydomain.com
Joomdle moodle path (joomla settings): http://mydomain/moodle

I had checked my Moodle config file to make sure the indicated path didn't include www.
Perhaps you could add this to the list of possible solutions to this issue.
I have noticed that the advice given to similar posts is to make sure the entered paths are the same... Well, beats me how this one worked...
Cheers
Nick
Última Edición: 1 year 8 months ago Por Nick.
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 1 year 8 months ago #4

have searched for this error and found no solution to this upto now, I am designing on localhost and all Urls are correct the same with those in the config file don know if it works on localhosts
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 11 months 2 weeks ago #5

  • Rob S
  • Rob S's Avatar
  • DESCONECTADO
  • Karma: 0
I have tried numerous tweaks as mentioned in the forum and still can't get a green checkmark on the system check for Joomdle Web services. no matter what I do I still get Received empty response from Moodle.
my Moodle URL is http://site-name/smu/
and my Joomla URL is http://site-name/joomla/

All other system checks work out

Joomla Version is Joomla! 2.5.14
Moodle version is Moodle 2.4.3

any thoughts what else I can try???
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 11 months 2 weeks ago #6

  • Chris
  • Chris's Avatar
  • DESCONECTADO
  • Karma: 29
@Nick. Yes you are correct. www and non www are different domains and while this can still work it is easier to have on the same domain. In the forum we discuss extensively about www and non www because many people do not understand that www and non www are different domains.

@kudzanai As mentioned there are many possible configurations. I now understand you are running locally which means that you may have a different set of issues. For those running locally, the issues will vary if you are on a local unix, windows or mac environment. You are not likely to have firewall issues but you man have resolving issues or connectivity issues. Without any further detail, we are not really able to help.


@Rob. Same as kuzanai, you have not really supplied us with much information to isolate your problem. Can you please provide us with greater details regarding your environment.
El administrador ha deshabilitado la escritura pública.

Joomdle web service Received empty response from Moodle 11 months 1 week ago #7

Hello Guys. I am also having problem in communicating with joomla moodle. I have both at the same dedicated server with firewall correct but always have information that there is no response from Moodle.
I have configured in moodle and joomla as illustrated in the images. Could someone help me? Thank you
Adjuntos:
El administrador ha deshabilitado la escritura pública.
  • Página:
  • 1
Time to create page: 0.170 seconds