Welcome, Guest
Experiences & Stories

Please do NOT use this section of the forum to request help if Joomdle does not work for you in some particular way. Your post will be deleted.

TOPIC: Cohort mapping : Not working after update to joomla 3.9

Cohort mapping : Not working after update to joomla 3.9 2 weeks 2 days ago #1

  • m.monza
  • m.monza's Avatar
  • Offline
Hi,

after updating to joomla 3.9 joomla user when importing in moodle are not save in the moodle cohorts according to the mapping set in the component JCohorts. Any clue?

Thanks!
The administrator has disabled public write access.

Cohort mapping : Not working after update to joomla 3.9 2 weeks 17 hours ago #2

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi.

I'm sorry, but I don't understand what you mean: Jcohort will put users in Moodle cohorts based on Joomla groups.
But you say you are importing users in Moodle? Those won't have any Joomla group, so they won't be added to any cohorts.
The administrator has disabled public write access.

Cohort mapping : Not working after update to joomla 3.9 1 week 6 days ago #3

  • m.monza
  • m.monza's Avatar
  • Offline
Sorry,

I've used wrong words.
I have users in joomla with their groups, with joomdle I want to import them to moodle like I've done until now. And it used to work: according to the mapping in cohort component I founded the users in moodle in the correct cohort. Now after updating to joomla 3.9, users from joomla are imported to moodle, but the are not in any cohort.

Am I now explaining more clear?

Thanks a lot!
The administrator has disabled public write access.

Cohort mapping : Not working after update to joomla 3.9 1 week 6 days ago #4

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
I have tested now with Joomla 3.9.1 and it seems to be working fine for me: created a new user in Joomla, adding him to a group that is mapped to a cohort. After saving, I can see the user in Moodle, appearing in the right cohort.
If you are using any other procedure, please explain steps so I can try to replicate.
The administrator has disabled public write access.