Welcome, Guest
How To / General

TOPIC: Rederection at login/logoff

Rederection at login/logoff 3 weeks 5 days ago #1

  • StefanGros
  • StefanGros's Avatar
  • Offline
Hi Antonio!

I am very sorry to bother you again, but a strange thing happens lately. On login my users get redirected to:
www.kepos.at/www.kepos.at/moodle/auth/jo...uemart%26view%3Duser

Ist obvious why the link doesn work but i have absolutely no idea where the rederection (also on logout) comes from.
Do you have any idea?

Regards
Stefan
The administrator has disabled public write access.

Rederection at login/logoff 3 weeks 4 days ago #2

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi.

I already replied you by email... maybe you missed it in spam folder. For some reason your emails go to my spam folder in gmail.
I copy what I wrote:
Check that you have https:// in from of URLs in Joomdle configuration in Joomla and Moodle.
The administrator has disabled public write access.

Rederection at login/logoff 3 weeks 1 day ago #3

  • StefanGros
  • StefanGros's Avatar
  • Offline
Hi Antonio
Sorry I didnt receive a Mail from you. I had troubles getting my moodle up running with https but that works fine now, but if i enter https:// in joomdl i get the 3 red signs in the connectivitycheck in joomdle.
Moodle URL in joomdle: www.kepos.at/moodle
Joomla Path in Joomdle Atuth Plugin: www.kepos.at
:(
Thanks for your help

But At least i removed the error at login and logoff with the change to https:/ in moodle. but still red signs.
Last Edit: 3 weeks 1 day ago by StefanGros.
The administrator has disabled public write access.

Rederection at login/logoff 3 weeks 19 hours ago #4

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
What's the message in last item? I guess the 3 checks failing are the last 3?
The administrator has disabled public write access.

Rederection at login/logoff 3 weeks 5 hours ago #5

  • StefanGros
  • StefanGros's Avatar
  • Offline
Yes the last 3
xxx cannot connect and vice versa
last Keine Rückmeldung von Moodle (No response from moodle)
The administrator has disabled public write access.

Rederection at login/logoff 2 weeks 6 days ago #6

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi.

Was system check working before you moved to https? If so, it seems the server is having problems connecting to itself over https.
The administrator has disabled public write access.

Rederection at login/logoff 2 weeks 4 days ago #7

  • StefanGros
  • StefanGros's Avatar
  • Offline
I solved the problem . I changed the connection method from cURL to file_get_contents and i get the systemcheck running with all grren lights. :)
Thanks again for you help.
P.S:: I realised that my subscription is running out soon and due to your really great support i will renew for sure!
Last Edit: 2 weeks 4 days ago by StefanGros.
The administrator has disabled public write access.

Rederection at login/logoff 2 weeks 2 days ago #8

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
I am glad that you solved the problem, even if my suggestions did not really help much :)

I am not sure of why the change made it work, though....maybe something to do with your curl version not trusting Let's encrypt certificates (just to say something, I have ni idea if this is the case. If you are interested in investigating more, just let me know)
The administrator has disabled public write access.

Rederection at login/logoff 1 week 3 days ago #9

  • StefanGros
  • StefanGros's Avatar
  • Offline
I am glad that it works. I am pragmatic. At the moment no further assistance neede. Thanks a lot!
The administrator has disabled public write access.