Welcome, Guest
How To / General
  • Page:
  • 1
  • 2

TOPIC: user login

user login 2 months 3 weeks ago #1

  • Green
  • Green's Avatar
  • Offline
hello
When an user create an account in joomla, it is ok in moodle but when, later, the user log in joomla, he is not automatically logged in moodle so problem...
www.informatique-bureautique.com/formation-windows-10
Thank's for your help
The administrator has disabled public write access.

user login 2 months 3 weeks ago #2

  • Antonio Durán
  • Antonio Durán's Avatar
  • Online
Hi.

Is system check all green?
Is Joomla and Moodle on same domain or different?
The administrator has disabled public write access.

user login 2 months 3 weeks ago #3

  • Green
  • Green's Avatar
  • Offline
system verification is green
same domain
The administrator has disabled public write access.

user login 2 months 3 weeks ago #4

  • Antonio Durán
  • Antonio Durán's Avatar
  • Online
Try changing the value of redirect-less SSO. to see if that helps.

Also, it could be a www/non-www session issue.
It seems you may have moodle configured to open on non-www url, but you are using www URL. Try changing Moodle to use www URL.
The administrator has disabled public write access.

user login 2 months 3 weeks ago #5

  • Green
  • Green's Avatar
  • Offline
I change less sso without result.
I don't know where to change moodle to use www url ; I looked but dont find any mention in the config.php or in the configuration of moodle...
The administrator has disabled public write access.

user login 2 months 3 weeks ago #6

  • Antonio Durán
  • Antonio Durán's Avatar
  • Online
You need to change URL in Moodle's config.php file, adding www.
Also you'll need to modify URL in Joomdle config in Joomal, to use new Moodle URL.
The administrator has disabled public write access.

user login 2 months 3 weeks ago #7

  • Green
  • Green's Avatar
  • Offline
If I write "www.informatique-bureautique.com/moodle" instead of "www.informatique-bureautique.com/moodle" in the configs, nothing works anymore...
The administrator has disabled public write access.

user login 2 months 3 weeks ago #8

  • Green
  • Green's Avatar
  • Offline
sorry :
If I write "www.informatique-bureautique.com/moodle" instead of "www.informatique-bureautique.com/moodle" in the configs, nothing works anymore...
The administrator has disabled public write access.

user login 2 months 3 weeks ago #9

  • Green
  • Green's Avatar
  • Offline
the "https://" are automatically deleted in this message ???
The administrator has disabled public write access.

user login 2 months 2 weeks ago #10

  • Antonio Durán
  • Antonio Durán's Avatar
  • Online
Not sure what you want to show us....
Please post:
- $CFG->wwwroot line from config.php in moodle folder
- What you have entered in Joomla and Moodle URLs in Joomdle config in Moodle and Joomla
The administrator has disabled public write access.
  • Page:
  • 1
  • 2