Welcome, Guest
How To / General

TOPIC: Joomdle Calendar

Joomdle Calendar 6 days 14 hours ago #1

  • Atle Johnsen
  • Atle Johnsen's Avatar
  • Offline
Latest joomdle and moodle.
Joomdle Calendar shows OK on frontend but I get an error when clicking on any date.
When clicking on a date I observe the URL in the browser:
www.mysite.com/nb/?option=com_joomdle&vi...=14&time=&Itemid=428
which is triggering an error (because of time=)
I tried on your demopage, clicked on a date and see the URL:
demo.joomdle.com/index.php?option=com_jo...year=2018&Itemid=519
As you can see this URL does not have "time=" ,but the proper content.
Any idea where the problem is ?
The administrator has disabled public write access.

Joomdle Calendar 6 days 5 hours ago #2

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi Atle.

In demo, URL is different because it is using older Moodle/Joomdle versions, where URL was set using day, month and year.
In newer Moodle versios, time param is used to select calendar day.

You say you are running latest Moodle, is that correct?
The administrator has disabled public write access.

Joomdle Calendar 5 days 20 hours ago #3

  • Atle Johnsen
  • Atle Johnsen's Avatar
  • Offline
Yes, I have the same situation with both Moodle 3.5 and 3.5.2.
For info the URLs I listed shows concatenated in this Kunena forum, so you have to hover cursor over them to see the full URL.

To me it seems that the time param is empty.

IF I manually edit the URL and replace 'time=' with '&day=10&mon=11&year=2018&Itemid=425' (just as in the URL of your demo site) it displays that date in Moodle correctly with no error.
The administrator has disabled public write access.

Joomdle Calendar 5 days 20 hours ago #4

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Moodle still accepts old syntax, so that's why it works when you enter the data directly.

Problem in this case is that URL has time variable empty for some reason....You can send me URL where I can see the module by email, in case I can spot some issue.
The administrator has disabled public write access.