× Joomdle 1.0 Installation

Https not working

5 months 3 weeks ago
GlenanPL
Posts: 17
More
Topic Author
Https not working #1
Hi,
I have a site that is OK since a lot of years. Its work’s fine. During Christmas holiday I decide to change and get https. It’s OK for Moodle and Joomla, But Joomdle not working.
In "system check" I have:
  • Joomla to Moodle HTTP connectivity Joomla cannot connect to Moodle
  • Moodle to Joomla HTTP connectivity Moodle cannot connect to Joomla
  • Joomdle Web Services Received empty response from Moodle
I have changed the URL parameters in Joomdle, Moodle. Regenerate the certificate in Joomdle, but it’s the same
Someone can help?
Thank’s in advance and happy new year!
PL
5 months 3 weeks ago 5 months 3 weeks ago by Antonio Durán.
Antonio Durán
Posts: 6902
More
Https not working #2
Hi.

If everything was working before moving to https, the problem may be that the server is having problems with the certificate for some reason.
You can create a test script and put it on your site with this code:
<?php
$a = file_get_contents ('https://YOURMOODLEURL');
echo $a;

Happy new year!
If that does not show the Moodle page, problem is https connection. In that case you could contact your hosting provider to see if they can help.
5 months 3 weeks ago
GlenanPL
Posts: 17
More
Topic Author
Https not working #3
Hi Antonio,
very nice!
We can find that nothing appears on the site but it’s ok with the same code on another site!
So, we change parameters of /etc/hosts and now the DNS redirects on cloudflare and it’s OK!
Thank you very much and have a nice day / night. B)
Regards!
PL