Welcome, Guest
Joomdle 1.0 Installation

TOPIC: Joomdle My Certificates module

Joomdle My Certificates module 2 weeks 1 day ago #1

  • Atle Johnsen
  • Atle Johnsen's Avatar
  • Offline
Joomdle My Certificate module does not support Moodle Custom Certificate type. Only Moodle Certificate type or Simplesertificate can be selected in the module.

Menu Item Type My certificates does however support Moodle Custom Certificate.
The administrator has disabled public write access.

Joomdle My Certificates module 1 week 6 days ago #2

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi Atle. Thanks for the info. I checked and you are right. But worst thing is that we already modified this module to add custom certificate support, but then forgot to properly release it. We are doing some server maintenace now, so until we can release it, I have sent it to you via email. Please let me know if you try it and have any issues.
The administrator has disabled public write access.

Joomdle My Certificates module 1 week 6 days ago #3

  • Atle Johnsen
  • Atle Johnsen's Avatar
  • Offline
Thanks Antonio for the updated module you sent by email. It seems to work fine, but with one issue. When I set 'Show button to send certificate' to Yes, I can see the email button and it opens a new page in the browser requesting to fill in some details. When I fill in and try to send I get the following Notice:

Notice
You must provide at least one recipient email address.
Email not sent

It seems that the software does not capture my inputs for email address. I get the same if I use a menu item to display My Certificates.
The administrator has disabled public write access.

Joomdle My Certificates module 1 week 4 days ago #4

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Thanks for the feedback and the bug report: I checked and I could replicate the problem, so I will look into it as soon as possible and get back to you.
The administrator has disabled public write access.

Joomdle My Certificates module 1 week 1 day ago #5

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
Hi.

I found the solution to this. If you want to do the change now, you need to edit file: components/com_joomdle/controllers/certificate.php
Change:
$email   = $this->input->get('email');
By:
$email   = $this->input->get('mailto', '', NULL);
The administrator has disabled public write access.

Joomdle My Certificates module 1 week 21 hours ago #6

  • Atle Johnsen
  • Atle Johnsen's Avatar
  • Offline
Thank alot. Works fantastic :-)
The administrator has disabled public write access.
Cron Job Starts