× Joomdle 1.0 Installation

A lot of requests with Joomdle?

5 months 3 weeks ago 5 months 3 weeks ago by GlenanPL.
GlenanPL
Posts: 17
More
Topic Author
A lot of requests with Joomdle? #1
Hi,
Du to the database, there is a lot of requests like



Looking to the database it’s possible to see



| column_name | data_type | character_maximum_length | numeric_precision | numeric_scale | is_nullable | column_type | column_default | column_key | extra |

| id | bigint | NULL | 19 | 0 | NO | bigint(10) | NULL | PRI | auto_increment |
| externalserviceid | bigint | NULL | 19 | 0 | NO | bigint(10) | NULL | MUL | |
| functionname | varchar | 200 | NULL | NULL | NO | varchar(200) | | | |


It seems to be Joomdle request, because when Joomdle is inactivated there isn’t this kind of request.
These queries arrive continuously on the database (several per second), so I think it must be a periodic task.
Is it possible to reduce the frequency of checks or is there a way to use a redis or apcu cache?
Thanks’ in advance

NB: Sorry to add an image for the code, but "code display" dosn't work's And Admin Tools scans ;)
Attachments:
5 months 3 weeks ago
Antonio Durán
Posts: 6902
More
A lot of requests with Joomdle? #2
Hi.

Searching that code in Moodle codebase, I see it is from function get_columns, that just returns info about columns in a database table.
So, these are not from Joomdle directly, although I guess they could be triggered by something in Joomdle code....
That said, I think the only periodic task in Joomdle is executed by the joomdlesession Joomla plugin, that is not enabled by default. Do you have it enabled?

> It seems to be Joomdle request, because when Joomdle is inactivated there isn’t this kind of request.
What do you mean with Joomdle inactivated? Did you uinstall, disable any plugins....
5 months 2 weeks ago
GlenanPL
Posts: 17
More
Topic Author
A lot of requests with Joomdle? #3
Hi Antonio.
I disable Joomdlesession.
We will see if there is less request !
Regard
PL