× Joomdle 1.0 Installation

system check failed

3 months 4 weeks ago 3 months 4 weeks ago by skyfranky.
skyfranky
Posts: 4
More
Topic Author
system check failed #1
Hi

I follow the document to setup, but system check failed for Joomdle Web Services & HTTP connectivity:
www.screencast.com/t/Ur8amHvya k

XML-RPC Error (1): Invalid token:
www.mysite.com/index.php?option=com_joom...server&format=xmlrpc k
I checked the token is correctly input.

JOOMLA: www.mysite.com k (latest ver joomla)
MOODLE: www.mysite.com/lms/ k (Moodle 3.6.2)

joomla_folder/logs/joomdle_system_check.xml
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /lms/webservice/xmlrpc/server.php
on this server.</p>
<p>Additionally, a 403 Forbidden
error was encountered while trying to use an ErrorDocument to handle the request.</p>
</body></html>
It seems the Joomdle auth plugin is not enabled in Moodle
>>ENALBED ALREADY
www.screencast.com/t/JP1a7mtkL4 k

Something is wrong with Joomdle Web Services setup
Something went wrong setting up Joomdle web services in Moodle. Try visiting Notifications page in Moodle Admin->Notifications.
If you get database errors with duplicate keys, try starting over by removing the offending rows/table. Execute these queries in your Moodle database:
>>NO ERRORS

Moodle Network authentication is not enabled in Moodle
You must enable the Moodle Network auth plugin in Moodle Admin->Users->Authentication->Manage Authentication.
>> THERE is NO such plugin
www.screencast.com/t/JP1a7mtkL4 k

Joomla URL is not configured in Joomdle auth plugin in Moodle
You need to enter Joomla URL in Joomdle auth plugin configuration, in Moodle Admin->Users->Authentication->Joomdle
>> It's set to www.mysite.com k

Check Joomla multi-language configuration and enter appropiate parameters in Moodle side if necessary
Check any mod_security rules that may deny XMLRPC traffic
Disable any Joomla security extensions you may have installed
>> DISABLED ADMINTOOLS ALREADY

Disable any Joomla SEF extensions you may have
>> USING JOOMLA DEFAULT SEF ONLY.
3 months 4 weeks ago
Antonio Durán
Posts: 6897
More
system check failed #2
Hi.

This seems to be the problem:
joomla_folder/logs/joomdle_system_check.xml
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /lms/webservice/xmlrpc/server.php
on this server.</p>

Try opening in the browser: yoursite.com/lms/webservice/xmlrpc/server.php
3 months 4 weeks ago
skyfranky
Posts: 4
More
Topic Author
system check failed #3
Hi
when I open
www.yoursite.com/lms/webservice/xmlrpc/server.php k

it will always redirect to below url, and nothing shown.
www.yoursite.com/lms k
3 months 4 weeks ago
Antonio Durán
Posts: 6897
More
system check failed #4
It seems something is preventing access to that URL, which is needed for Moodle web services,as the message indicates:
You don't have permission to access /lms/webservice/xmlrpc/server.php
on this server.

If you don't know what can cause this, you may want to ask your hosting provider, as they might be able to give you the reason.
3 months 4 weeks ago
skyfranky
Posts: 4
More
Topic Author
system check failed #5
I put a test.html in that folder to test access right, and it works correctly. so this is not file and folder access permission issue.
www.mysite.com/lms/webservice/xmlrpc/test.html k

this is openning /lms/webservice/xmlrpc/server.php , it redirects to /lms/
what causing the redirection?
3 months 4 weeks ago
Antonio Durán
Posts: 6897
More
system check failed #6
I don't know. Something's wrong with your host and/or your Moodle.
This is what you should get:
moodle.org/webservice/xmlrpc/server.php k
3 months 3 weeks ago
skyfranky
Posts: 4
More
Topic Author
system check failed #7
There is no error, just redirect. Very hard to troubleshoot. any way to narrow down the issue?
3 months 3 weeks ago
Antonio Durán
Posts: 6897
More
system check failed #8
I would contact hosting provider and point them to the file to see if they can help.
Cron Job Starts