× Joomdle 1.0 Installation

System Check Error - Joomdle version is different in Joomla and Moodle

5 months 2 weeks ago
Anil
Posts: 12
More
Topic Author
System Check Error - Joomdle version is different in Joomla and Moodle #1
I updated Joomdle from Joomla update.
And manually installed new auth_joomdle.zip & enrol_joomdle.zip.
Moodle is not allowing me to upgrade - with a message "Dependencies check failed for auth_joomdle"

System Error - prntscr.com/msikny k
Moodle Error - prntscr.com/msim81 k


Below is my configuration
Joomla 3.8.12
Joomdle 1.2.3
Moodle 3.1.9
5 months 2 weeks ago
Antonio Durán
Posts: 6945
More
System Check Error - Joomdle version is different in Joomla and Moodle #2
Hi.

I am sorry, but you won't be able to upgrade Joomdle on Moodle unless you upgrade Moodle.
Current Joomdle requires Moodle >= 3.6

If you cannot upgrade Moodle right now, don't worry. Even with the error in system check, Joomdle should work without any issues.
5 months 2 weeks ago
Anil
Posts: 12
More
Topic Author
System Check Error - Joomdle version is different in Joomla and Moodle #3
I am preparing for the upgrade to Moodle 3.6. Also, upgrading to PHP 7.1 for PHP 5.6 for both Joomla & Moodle.
In my development site, I upgraded Joomla to 3.9. However, when I move the site to PHP 7.1 the Joomdle system check fields are changing.

For PHP 5.6
prnt.sc/mtclla k

For PHP 7.1
prnt.sc/mtcivr k

For PHP 7.1 last three options under System Check for missing

Joomla to Moodle HTTP connectivity
Moodle to Joomla HTTP connectivity
Joomdle Web Services

Is this is normal or something is wrong?
Also, for PHP 7.1 my server hosting guys confirm that XML-RPC PHP extension is enabled. However, under system check, it reflects error message.

Guide us to fix this
5 months 2 weeks ago
Antonio Durán
Posts: 6945
More
System Check Error - Joomdle version is different in Joomla and Moodle #4
In 7.1, message is clear: XMLRPC is not enabled. Tell your server guys do double check.
Cron Job Starts