× Joomdle 1.0 Installation

crea usuario en moodle pero no en joomla

2 months 1 week ago
almendro18
Posts: 3
More
Topic Author
crea usuario en moodle pero no en joomla #1
Tenemos un sistema con joomla 3.9.3, moodle 3.6.2 y joodle 1.2.3.

La comprobación del sistema aparece como todo correcto, y al crear un usuario en joomla el usuario es replicado en joomdle y moodle, pero no ocurre lo mismo cuando la acción se realiza desde moodle, el usuario es creado en joomdle pero no existe en joomla, debes hacer la sincronización manualmente desde el propio plugin joomdle.

Hemos reinsitalado y reconfigurado el plugin pero no conseguimos hacerlo funcionar.

Un saludo y gracias
2 months 1 week ago
Antonio Durán
Posts: 6874
More
crea usuario en moodle pero no en joomla #2
Hola.

Habéis activado la opción de sincronizar usuarios de Moodle a Joomla en la config de Joomdle en Moodle? Viene desahabilitada por dedecto.
2 months 1 week ago
almendro18
Posts: 3
More
Topic Author
crea usuario en moodle pero no en joomla #3
Si, la tenemos activada.

Tenemos otra plataforma con versiones diferentes de moodle y joomla que funciona correctamente y la configuración está replicada.
2 months 1 week ago
Antonio Durán
Posts: 6874
More
crea usuario en moodle pero no en joomla #4
Pues entonces no sé cual puede ser el problema. No me suena haber visto ese problema anteriormente....lo único que se me ocurre es hacer debug sobre el código cuando creas un usuario en Moodle, a ver si se ve que es lo que pasa.
2 months 4 days ago
almendro18
Posts: 3
More
Topic Author
crea usuario en moodle pero no en joomla #5
Hola Antonio,

Hemos arreglado el error que te comentábamos, creemos que es un error en vuestro código ya que no entendemos porque hay un return vacío en la primera linea del fichero de moodle auth/joomdle/localib.php, lo que impide que ejecute el código de la función que resultaría en la creación del usuario en joomla. Si se quita dicho return funciona todo correctamente.

Un saludo
2 months 2 days ago
Antonio Durán
Posts: 6874
More
crea usuario en moodle pero no en joomla #6
Tienes razón! No sé lo que habrá pasado para que aparezca ese return ahí :( Muchas gracias por el aviso. Sacaremos una nueva versión cuanto antes para corregir este problema.