Welcome, Guest

TOPIC: [Closed] Cant save Moodle URL in Joomdle

[Closed] Cant save Moodle URL in Joomdle 6 years 5 months ago #1

  • devo
  • devo's Avatar
  • Offline
  • Karma: 0
Hello,
I set up Moodle for Joomdle, and installed Joomdle 0.7 after that (in Joomla 1.6).
Then Im supposed to put in the Moodle URL in Joomdle Configuration but
when I do that, it disappears after I click on "Save" or "Save&Close"
I tried to insert elearning.business-english-academy.de
WHat can I do?

(I have put in www.google.de for fun and it worked???) :silly:

-neither can I change any options like Moodle version,Connection method it all gets set back
Last Edit: 6 years 5 months ago by Chris.
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 5 months ago #2

  • devo
  • devo's Avatar
  • Offline
  • Karma: 0
the adress without http worked!
now I get
COM_JOOMDLE_JOOMDLE_WEB_SERVICES_ERROR 7021
at the system check..whats that?
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 5 months ago #3

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
  • Karma: 159
That means you need to add your IP to moodle xmlrpc hosts list.

As for not being able to save config options: I have heard of this problem for a couple of users, but could not find the cause.
Really, options are saved, but it takes a long time for them to be updated. Really weird.
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 5 months ago #4

  • devo
  • devo's Avatar
  • Offline
  • Karma: 0
I did add the ip (178.77.80.241/32) and now Im getting the following error:
Joomla URL seems to be misconfigured in Joomdle auth plugin in Moodle
the url is www.business-english-academy.de
whats wrong with that...??
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 5 months ago #5

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
  • Karma: 159
Did you set the settings for SEF in Moodle side?
Joomla SEF enabled and default language set to 'en'.
The administrator has disabled public write access.
The following user(s) said Thank You: devo

Re: Cant save Moodle URL in Joomdle 6 years 5 months ago #6

  • devo
  • devo's Avatar
  • Offline
  • Karma: 0
just did that and it worked.thanks.
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 2 weeks ago #7

  • vcube04
  • vcube04's Avatar
  • Offline
  • Karma: 0
Hi Antonio:

Yes, I too have the same update problem. Try changing ANYTHING on the configuration screen and save it, you notice that everything gets reset.

I have tried clearing the browser cache, restarting my (local) XAMPP, and setting the config items multiple times, but still it gives me this problem. After many such gyrations, it is able to save it. But this is really exhausting and am praying we have a solution for this. Your kind attention appreciated!
Thanks
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 2 weeks ago #8

  • Antonio Durán
  • Antonio Durán's Avatar
  • Offline
  • Karma: 159
This is fixed in R0.82. It was caused by Joomla caching.
The administrator has disabled public write access.

Re: Cant save Moodle URL in Joomdle 6 years 2 weeks ago #9

  • vcube04
  • vcube04's Avatar
  • Offline
  • Karma: 0
Sorry here's my update; Joomla 2.5.6; Moodle 2.3, Joomdle 0.82

Anyway, after clearing cache and repeated saving, finally I am able to get the options to stick. Thanks for the clarification though.
The administrator has disabled public write access.
Cron Job Starts