× How To / General

Updated Joomdle in Moodle & Joomla and Bridge Stopped Working

2 days 18 hours ago
thefluffyshrimp
Posts: 5
More
Topic Author
Updated Joomdle in Moodle & Joomla and Bridge Stopped Working #1
Hello!

This is so strange. I updated the Joomdle plugin in Joomla (using the 1-click upgrade process) and then updated the Joomla plugin in Moodle (manual upload). Upon doing so, it appears that my bridge between the platforms "broke." I can no longer login to Moodle and be logged into Joomla and vise-versa. I double-checked the System Check and it says everything is working fine. Weird. So I double-checked the auth tokens in both systems (to see if the upgrade overrode or changed them) and they are still the same as they were before. So weird. I tried deleting my cookies and even tried a new browser, but it still won't work. So weird.

Any reason why this might have happened?

Thank you so much for your help!
Best Regards,
thefluffyshrimp
2 days 14 hours ago
Antonio Durán
Posts: 6897
More
Updated Joomdle in Moodle & Joomla and Bridge Stopped Working #2
Hi.

If system check is all green, I guess the only problem you are having is Single Sign On.

As for why this can happen: did you make any other changes? It's weird that system check is all green after update, but SSO suddenly does not work.
Maybe you upgraded PHP, installed some security component,....

If you cannot find the issue, you can write to development at joomdle email and I will try taking a look.
Cron Job Starts