Parece que la URL de Joomla no es correcta en la configuraci

7 years 11 months ago
Yelitza Cintron
Posts: 23
More
Topic Author
Parece que la URL de Joomla no es correcta en la configuraci #1
Hola Antonio,

me sale este error al cuando veo la comprobación del sistema: Parece que la URL de Joomla no es correcta en la configuración del plugin de autenticación Joomdle en Moodle

Por ejemplo, cuando me registro como usuario de prueba en Joomla, todo bien, veo los cursos disponibles, etc... por lo tanto toda la configuración está bien, pero cuando me inscribo en un curso, me pide volverme a logguear en Moodle, cuando logueo con la info correcta me sale "INVALID LOGIN, PLEASE TRY AGAIN"... cuando voy a Moodle como administradora me aparece un usuario con todo la info en blanco... por ejemplo, cuando lo abro, sale el user mío pero no veo nada más... No hay dirección, que BTW, en el Moodle 2.0 estaba todo bien, tuve que bajarlo a 1.9 para poder usar el módulo del certificado... pero anyways, la cosa es que por alguna razon no se entran todos los datos al moodle, por lo que no me deja registrarme allá y ver el curso...

También, cuando con moodle 2.0 entraba al curso, no me llevaba al carrito de compras para pagar, me llevaba directo al curso, inclusive cuando el curso estaba registrado ya en VirtueMart...

A que se puede deber esto? PS NO he podido comprobar si en el esistema de moodle 1.9 me inscribe sin cobrarme antes pues no he podido entrar al curso desde joomla... Plis me urge!! Gracias!
7 years 11 months ago
Yelitza Cintron
Posts: 23
More
Topic Author
Parece que la URL de Joomla no es correcta en la configuraci #2
En moodle como admisnitradora arreglé la info manualmente (que no es lo que quisiera pues imagínate tener que hacerlo cada vez que alguien se registra) sólo para poder entrar desde joomla... y efectivamente, me pasa al curso sin cobrarmelo... :S
7 years 11 months ago
Antonio Durán
Posts: 6897
More
Parece que la URL de Joomla no es correcta en la configuraci #3
Hola.

El proble de la URL no correcta puede deberse a dos cosas:
a) Si de verdad estas usando R0.4, actualiza la version, que tiene mejor check de errores
b) Que tengas algun problema en tu joomla: Visita la pagina tujoomla.com/xmlrpc/index.php para ver si tienes algun error php (deberia salir solo un error xml si va ok)
7 years 11 months ago 7 years 11 months ago by Yelitza Cintron.
Yelitza Cintron
Posts: 23
More
Topic Author
Parece que la URL de Joomla no es correcta en la configuraci #4
Ok, pero mira lo que sucede... yo tenía instalado y trabajando completamente 100% funcional con el Moodle 2.0. todo trabajaba perfectamente, el unico problema era que para poder incluir el módulo del certificado tenía que instalar el moodle 1.9... y con el moodle 1.9 es que tengo estos problemas...

- Parece que la URL....
- No sincroniza correctamente los usuarios registrados en Joomla y vuelve a pedir login details cuando se inscribe en el curso que marca y cuando entras el user y password con el cual te registraste en Joomla y sale "Invalid Login, please try again"... (Cuando voy a Moodle yo como administrador, están como usuarios nuevos, pero todo vacío, solo pasa el User name pero no pasa la información de contacto, es decir, el password, nombre, apellidos, etc)
- Al loguearme con mi cuenta de administradora, me pasa directo al curso sin cobrarme antes... Como si estuviera gratis, pero yo le puse precio tanto en Virtuemart como en Moodle...

Any suggestion?
7 years 11 months ago
Antonio Durán
Posts: 6897
More
Parece que la URL de Joomla no es correcta en la configuraci #5
Olvidate de los logins y las compras y todo si tienes un error en el system check, porque nada funcionará bien hasta que lo arregles.

No me has dicho si sigues con R0.4, o has actualizado.
Lo único que se me ocurre sin saber mas es que re-compruebes que la url tiene el http:// y es correcta.