× Joomdle 1.0 Installation

Joomdle fail to connect Joomla to Moodle while nginx listening to port 7025

1 month 3 weeks ago 1 month 3 weeks ago by Alex Chiou. Reason: URL modification
Alex Chiou
Posts: 1
More
Topic Author
Joomdle fail to connect Joomla to Moodle while nginx listening to port 7025 #1
Hi, I install both Joomla and Moodle on the same nginx server (the IP is 192.168.1.227) on different folder.
My nginx server is listening to port 7025,
the URL of my joomla is: h t t p://60.250.19.168:7025/joomla
and the URL of my moodle is: h t t p://60.250.19.168:7025/moodle
I have successfully installed joomdle 2.0 on both Joomla and moodle,
However, after I input the above URL in the configuration setting of Joomdle & save it , the joomdle control panel cannot act normally.
The joomdle is blocked and there is no any response after clicking any button on control panel.
The error log of nginx are as follows:

2021/10/07 17:28:21 [error] 16013#16013: *1342 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.254, server: localhost, request: "GET /joomla/administrator/index.php?option=com_joomdle&view=check HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "60.250.19.168:7025", referrer: " 60.250.19.168:7025/joomla/administrator/..._joomdle&view=config k"
2021/10/07 17:28:22 [error] 16013#16013: *1342 open() "/usr/share/nginx/html/favicon.ico" failed (2: No such file or directory), client: 192.168.1.254, server: localhost, request: "GET /favicon.ico HTTP/1.1", host: "60.250.19.168:7025", referrer: " 60.250.19.168:7025/joomla/administrator/...m_joomdle&view=check k"

Please give me your advice on how to fix this problem of setting URL in Joomdle's configuration
Attachments:

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
Antonio Durán
Posts: 7331
More
Joomdle fail to connect Joomla to Moodle while nginx listening to port 7025 #2
Hi.

I have not used NGINX much, but I know it's been used with Joomdle without problems, so I don't know what your issue can be.

The first thing I would try is to check if doing a wget from inside the server works.
I mean this:
wget h t t p://60.250.19.168:7025/moodle

This has to be executed inside the server, to see if there is any issue connecting to the server from itself.

Please Log in or Create an account to join the conversation.