× R0.22 and earlier: No Longer Supported

[Solved] start joomdle

11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #11
No. It does not show anything.

:(
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #12
Then something is going wrong. It should at least show the echos.
Are you sure it is in the right place?
Put another file, test2.php, in the same place with only:
<? echo "HI"; ?>

And see if it shows up.
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #13
Hi Antonio.

Excuse my stupidity. Lacked the parameter "php".
Example: <?php echo "hi"; ?>
understand?
Redid the test 1, correctly, I got the following result:

Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in C:\wamp\www\test.php on line 3

Warning: file_get_contents(http: //localhost/moodle) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in C:\wamp\www\test.php on line 3

Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in C:\wamp\www\test.php on line 5

Warning: file_get_contents(http: //localhost/moodle/mnet/xmlrpc/server.php) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in C:\wamp\www\test.php on line 5

I hope I have done right now. ;)
Marcos
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #14
It seems as the option you turned off is still off, isn`t it? I gives the same error as when you changed it...
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #15
Yes. The previous test was with the option allow_url_fopen off.

Now, this is the result with the option allow_url_fopen on:

Warning: file_get_contents(http: //localhost/moodle) [function.file-get-contents]: failed to open stream: Uma tentativa de conexão falhou porque o componente conectado não respondeu corretamente após um período de tempo ou a conexão estabelecida falhou porque o host conectado não respondeu. in C:\wamp\www\test.php on line 3

Warning: file_get_contents(http: //localhost/moodle/mnet/xmlrpc/server.php) [function.file-get-contents]: failed to open stream: Uma tentativa de conexão falhou porque o componente conectado não respondeu corretamente após um período de tempo ou a conexão estabelecida falhou porque o host conectado não respondeu. in C:\wamp\www\test.php on line 5

Fatal error: Maximum execution time of 120 seconds exceeded in C:\wamp\www\test.php on line 5
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #16
That's bad. If that does not work, is not Joomdle's fault, it is because the file_get_contents function is not working at all. I tried searching on the net, but nothing showed up, so I don't know how to continue :(
As I don't use Windows I can't give you any pointers. No one using Linux or a hosted domain is having these issues :( But one person time ago had the same issue in Windows with XAMPP, so I guess there is something strange going on.

Maybe you could find out more in some windows php forum...If you do,please share :)

I will try to ask someone who uses Windows to install it and try, to see if we can get any more details.

Antonio
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #17
Another test. Put only this in the file:
echo "GET 1:".file_get_contents (' google.es k');

To see if the problem is serving the files or getting them.
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #18
This is the result:

Warning: file_get_contents(google.es) [function.file-get-contents]: failed to open stream: No such file or directory in C:\wamp\www\test.php on line 3
GET 1:

:(
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #19
I missed the http// because of kunena, did you put it?
The topic has been locked.
11 years 9 months ago 11 years 9 months ago by Marcos Joia.
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #20
Oh! Sorry.
I'm a stupid. :S

Now yes. :)
The test showed:

GET1 the top
and below, the page Google
The topic has been locked.