× R0.23 No Longer Supported

Error while using NAT'ed IP

11 years 2 months ago
dev
Posts: 2
More
Topic Author
Error while using NAT'ed IP #1
Greetings,

i've been able to use the joomdle component with a real ip with complete success, but when i use a NAT'ed ip i have trouble signing in from jooomla to moodle...the authentication process jus does not complete. is it possible to use a NAT'ed ip when using joomdle?


Any suggestions are welcome at the earliest.

Please Log in or Create an account to join the conversation.

11 years 2 months ago
Chris
Posts: 2118
More
Error while using NAT'ed IP #2
While I do not have any experience using Joomdle through a NAT at this time. Technically, there should be a way as long as its all transparent to Joomdle, Joomla, Moodle (really any application). Depending on the device(s) you have setup in your network you may need to set up some form of translation, direction or even tunneling. Without know how you are using your NAT its a little difficult to comment.

For example for certain games you will need to configure your NAT to route particular protocols and/or ports. Similarly, something may need to happen.

I would set up and test the environment entirely without a NAT a first to ensure all is working. And then insert the NAT into the equation. If you suddenly run into problems, at least you know that you will need to configure your NAT and/or applications.

Please Log in or Create an account to join the conversation.

11 years 2 months ago
dev
Posts: 2
More
Topic Author
Error while using NAT'ed IP #3
hi,

Thanks for looking into my post chris, i actually did test using a real ip (public ip actually) and joomdle worked fine without any problems.

It was more economical for us to move to a NAT'ed ip so we began testing joomdle on it. but unfortunately it didnt work out as planned.

joomla and moodle sites opened fine seperately, but when trying to authenticate from joomla to moodle, the process fails. :(

I do have all ports opened for my NAT'ed ip. and i have enabled all TCP and UDP traffic to be allowed.
(note: we're using a watchguard firewall)

additionally, i've configured joomla and moodle to point to my public address rather than my internal ip.

I can enable my setup to be viewed publicly in case this is required.

Thanks and regards,

Dev

Please Log in or Create an account to join the conversation.

11 years 2 months ago 11 years 2 months ago by Chris.
Chris
Posts: 2118
More
Error while using NAT'ed IP #4
We have seen similar situations before with Joomdle installations but more widely with any applications that are trying to connect using furl_open, a php command. Many firewalls prohibit this command by default but can be configured to allow it. See this discussion, while the firewall is Sonic, it is still a firewall.
bugs.php.net/bug.php?id=40197 k
You can see the solution down near the bottom by changing one of the firewall settings.

Note this is different than allowing ports to a particular IP address. Instead this is about the PHP Headers where this command is using HTTP 1.0.

You can do a search for furl_open, php, your firewall php get contents for more details.

Also, if you would like you can try using R0.25 which supports both furl_open and CURL which is another protocol for getting remote data between applications. To update to R0.25 would require a complete re-installation of Joomdle. Joomdle in Joomla and Moodle.

Let me know if you would like the R0.25 file and I can send it through email.

Chris

Please Log in or Create an account to join the conversation.