[Solved] SSO doesn't work Moodle -> Joomla, ok the other way

5 years 11 months ago 5 years 11 months ago by Antonio Durán.
Mark Schultz
Posts: 4
More
Topic Author
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #1
SSO doesn't work Moodle --> Joomla, ok the other way

-- running final J2.5 release, Joomdle 0.9, latest moodle 2.8.3+, php 5.4.38
-- moodle login returns user not found, can login once user is in moodle databse
-- SSO redirect not turned off
-- system check in Joomdle component all green

Anybody know where to look next? thanks.

Please Log in or Create an account to join the conversation.

5 years 11 months ago 5 years 11 months ago by Chris.
Chris
Posts: 2118
More
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #2
- Do the users exist in Moodle? Have you syncronised the users the first time?
- Were the users Moodle users (not Joomla) before the integration?
- What happens when you create a new user from Joomla side? Are they created in Moodle with data syncronized? Can they log in successfully?

You say you are using Joomdle 0.9 - this is very very old and you should upgrade as there will be numerous bug fixes since that version. Perhaps you mean Joomdle 0.9x ? Note: You can find the Joomdle changelog here www.joomdle.com/support/joomdle-change-log k

Please Log in or Create an account to join the conversation.

5 years 11 months ago
Mark Schultz
Posts: 4
More
Topic Author
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #3
Using the 0.9 version still available from your download page because this site still uses J2.5. Won't be upgrading til later this year.

- Do the users exist in Moodle?
no.

Have you syncronised the users the first time?
no. would I select all users and click "add users to moodle" ?

- Were the users Moodle users (not Joomla) before the integration?
all joomla to start.

- What happens when you create a new user from Joomla side? Are they created in Moodle with data syncronized?
yes

Can they log in successfully?
yes

thanks

Please Log in or Create an account to join the conversation.

5 years 11 months ago
Antonio Durán
Posts: 7252
More
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #4
User needs to exist in Joomla and Moodle first for SSO to work.

Please Log in or Create an account to join the conversation.

5 years 11 months ago
Mark Schultz
Posts: 4
More
Topic Author
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #5
thanks. so would I would I select all users and click "add users to moodle" ?

Please Log in or Create an account to join the conversation.

5 years 11 months ago
Antonio Durán
Posts: 7252
More
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #6
Yes, you can do that. But users will be created automatically if they are enroled to a course anyway, so depending on the case you may not need to do it.

Please Log in or Create an account to join the conversation.

5 years 11 months ago
Mark Schultz
Posts: 4
More
Topic Author
[Solved] SSO doesn't work Moodle -> Joomla, ok the other way #7
ok thanks for your help, guys.

Please Log in or Create an account to join the conversation.