Moodle4

From Joomdle
Revision as of 18:56, 20 April 2022 by Antonio (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Support

Joomdle 2 supports Moodle 4.

Upgrading to Moodle 4

When you start the upgrade of an existing site to Moodle 4, you will see this messasge in the Enviroment check:


It has been detected that the XML-RPC Web Service protocol is enabled on your site. This feature relies on the PHP XML-RPC extension which is no longer maintained by PHP.

Xmlrpcwarning.png


This is shown because you have the XML-RPC protocol enabled for Joomdle to work. In PHP 8, XML-RPC is not available, so an alternative is needed.


With Joomdle 2, you can use REST web services instead, so XML-RPC is not required.


If you want to change to REST and get rid of the warning, follow these steps:

  • In Joomdle configuration in Moodle, set Web services protocol to REST.
  • In Joomdle configuration in Joomla, set Web services to REST
  • Go to Moodle->Site Administration->Server->Web Services->Manage protocols and disable XML-RPC protocol
  • In Joomla backend, go to System check page in Joomdle to make sure everything keeps working as expected