× R0.22 and earlier: No Longer Supported

[Solved] start joomdle

11 years 9 months ago 11 years 9 months ago by Antonio Durán.
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #1
Hi Antonio,

I did the following:
1 - I installed the modules Joomdle
2 - I installed the plugins Joomdle
3 - Enable all plugins, managing plugin
4 - Enable the modules of courses, modules to manage

Now I am with the following problem:
When I go to Administer modules and enables Joomdle courses, the courses will not load on the frontend. The following error appears:

Warning: file_get_contents(http://localhost/moodle/mnet/xmlrpc/server.php) [function.file-get-contents]: failed to open stream: Uma tentativa de conexao falhou porque o componente conectado nao respondeu corretamente apos um periodo de tempo ou a conexao estabelecida falhou porque o host conectado nao respondeu. in C:\wamp\www\conhecimento\modules\mod_joomdle_courses\mod_joomdle_courses.php on line 55


What can be wrong?
The topic has been locked.
11 years 9 months ago 11 years 9 months ago by Antonio Durán.
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #2
Hi, I think maybe it is because you omitted http ://?
Try configuring it with http ://localhost/moodle (removing the space I put so kunena does not mess with the link)

Antonio
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #3
No, that's ok...

the error message contains the HTTP

Warning: file_get_contents(http: //localhost/moodle/mnet/xmlrpc/server.php) [function.file-get-contents]: failed to open stream: Uma tentativa de conex�o falhou porque o componente conectado n�o respondeu corretamente ap�s um per�odo de tempo ou a conex�o estabelecida falhou porque o host conectado n�o respondeu. in C:\wamp\www\conhecimento\modules\mod_joomdle_courses\mod_joomdle_courses.php on line 55

when I post, do not put space ... and turned hyperlink

sorry
:(
The topic has been locked.
11 years 9 months ago 11 years 9 months ago by Antonio Durán.
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #4
Ah :) I didn't though of that.

I see that you are on Windows. I have never installed on Windows (only use Linux) but I think someone did it fine (I believe, but I am not sure). If anyone reads this and can confirm... ;)

If you go with your browser to "http: //localhost/moodle/mnet/xmlrpc/server.php", what do you get?

You should get a file like the one attached.

Antonio

Attachment server.txt not found

Attachments:
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #5
Hi Antonio

the message that appears is that:

The XML document is not associated with styles. The document structure is represented below.

<methodResponse>
<fault>
<value>
<struct>
<member>
<name>faultCode</name>
<value>
<int>713</int>
</value>
</member>
<member>
<name>faultString</name>
<value>
<string>Could not find the function or function prohibited for RPC.</string>
</value>
</member>
</struct>
</value>
</fault>
</methodResponse>

What is wrong? The tag "int" has different value of the file that you posted..
:(

Marcos
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #6
Different number is OK, I tested on a misconfigured moodle.
When I test with the real one, I also get the 713 error.

So, the URL is OK because you get the XML file, so I don't know what can be happening.
I am thinking that this must be Windows-related, as I checked by old mail and found this problem happening to two Windows users.

One thin I never looked is that you have activated allow_url_fopen in PHP. Check your php info to confirm.

As I told you I don't use Windows, so I can't replicate your setup, but I am very interested in making this work in Windows, so if that does not help, we will continue trying ;)

Antonio
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #7
Yes, you're right!

The allow_url_fopen was activated. But when I disable it, it displays two error messages:

Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in C:\wamp\www\conhecimento\modules\mod_joomdle_courses\mod_joomdle_courses.php on line 55

Warning: file_get_contents(http: //localhost/moodle/mnet/xmlrpc/server.php) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in C:\wamp\www\conhecimento\modules\mod_joomdle_courses\mod_joomdle_courses.php on line 55

What's the next suggestion?

Marcos
The topic has been locked.
11 years 9 months ago 11 years 9 months ago by Antonio Durán.
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #8
Searching google it seems that is expected behaviour when you turn that option off.

I just made created a test file to try to find out what is going on.
Copy it to your document webroot as test.php and go to localhost/test.php with the browser.

It should show a malformed Moodle and the 713 error message at the end.

Antonio

Attachment test.txt not found

Attachments:
The topic has been locked.
11 years 9 months ago
Marcos Joia
Posts: 15
More
Topic Author
[Solved] start joomdle #9
No.
:(

I tested with allow_url_fopen turned on and off. The result was the same:

No message was displayed by the browser.
The topic has been locked.
11 years 9 months ago
Antonio Durán
Posts: 7331
More
[Solved] start joomdle #10
Just to reconfirm that it ix executing correctly, I added some echos.
Try this one and tell me what you get.

Attachment test-20100219.txt not found

Attachments:
The topic has been locked.