× R0.23 No Longer Supported

SSO problem: new joomla user not added to moodle

11 years 5 months ago
Giuseppe Sciacchitano
Posts: 8
More
Topic Author
SSO problem: new joomla user not added to moodle #1
Hello,

I have read the forum but could'n find a solution to this issue.
I seem to have some trouble in making joomdle work as expected.
I am using a local test environment on MacOs X Leopard with a fresh copy of joomla and moodle installed and working.
I installed joomdle following all the steps explained in the documentation but when i create a new user using the joomla User Manager the new user does non appear in moodle's list of users.

Joomla does not display any error about this. it just writes "Successfully saved User: username"

xml_rpc is present and web services are on.

joomla is installed in http: //localhost/joomla
and moodle is in http: //moodle (without the space before //)

the two urlas are the same used in the configuration panels.
I cannot understand what can be wrong.

Could it be something related to domain translation between localhost, 127.0.0.1 or pose.local (the local name of my Mac?) If so how can i fix the problem in the .htaccess file?

Otherwise, Could you give me some hints about where to put some (echo, print_r or so...) debbuging code in joomdle sources to investigate the issue?

Thank you in advance

Ciao,
Giuseppe Sciacchitano

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Antonio Durán
Posts: 7311
More
SSO problem: new joomla user not added to moodle #2
Hi. First thing would be to know if anything is working at all, as SSO requires everything else to work before it does.

So, starting with the easiest to debug: is the joomdle courses module showing moodle courses?

Please Log in or Create an account to join the conversation.

11 years 5 months ago
AMI
SSO problem: new joomla user not added to moodle #3
I have the same problem.
I can create user in Joomla but it will be added in Moodle database only when i login to Moodle with that user. Which means that Moodle can read the Joomla database.
Still, there is no change in Moodle database when i create a user in Joomla.
More, i cannot get to displaying anything from Moodle in Joomla (i respected all the steps for installing Joomla, Moodle and Joomdle). I cannot display any Moodle courses, teachers .. not anything under Joomle.

The link is: www.info.ase.ro/test/Joomla k

I also made a test account:
username: test
password: test

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Giuseppe Sciacchitano
Posts: 8
More
Topic Author
SSO problem: new joomla user not added to moodle #4
antonio wrote:

Hi. First thing would be to know if anything is working at all, as SSO requires everything else to work before it does.

So, starting with the easiest to debug: is the joomdle courses module showing moodle courses?



Yes, the joomdle courses module shows available courses and moodle is correctly opened in the wrapper iframe.

let's try the next debugging session ;-)

thank you for your help

Giuseppe

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Antonio Durán
Posts: 7311
More
SSO problem: new joomla user not added to moodle #5
Ok pignus, a couple of questions:
- Have you enabled the option "Auto create users" in Joomdle component config?
- Does it create the users in Moodle when you log in Joomla with a new user an dclick on the SSO links in the module?

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Antonio Durán
Posts: 7311
More
SSO problem: new joomla user not added to moodle #6
ami: I don't see any courses in your moodle installation.

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Giuseppe Sciacchitano
Posts: 8
More
Topic Author
SSO problem: new joomla user not added to moodle #7
antonio wrote:

Ok pignus, a couple of questions:
- Have you enabled the option "Auto create users" in Joomdle component config?
- Does it create the users in Moodle when you log in Joomla with a new user an dclick on the SSO links in the module?


Yes! it did it!

I did never do the last step, i was always creating the user in joomla and then checked to see in moodle if it appeared in the list of users without accessing the module from joomla.

Thank you very much.

pignus

Please Log in or Create an account to join the conversation.

11 years 5 months ago
AMI
SSO problem: new joomla user not added to moodle #8
Well, i actually added some courses and i don't know the reason why I am not able to see them under Joomla.

Could I also ask what module is this about? (Does it create the users in Moodle when you log in Joomla with a new user an dclick on the SSO links in the module?)

I noticed that if I open a new tab where i log on into Moodle with, let's say, user student, then when i go and click inside Jommla on courses link, no matter what user i am logged on with in Joomla, it opens the Moodle page logged on as student.

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Antonio Durán
Posts: 7311
More
SSO problem: new joomla user not added to moodle #9
Pingus: that is a way of working. It was the first implemented.

You also have the possibility of creating the users in Moodle without having them to click on module links (just as you were expecting).
For that, auto create users must be set in joomdle component, and joomdlehooks plugin must be enabled.

Please Log in or Create an account to join the conversation.

11 years 5 months ago
Antonio Durán
Posts: 7311
More
SSO problem: new joomla user not added to moodle #10
ami: forget about SSO until you get moodle courses to show in joomla. That is the basic thing that needs to work.

I juste entered www.info.ase.ro/test/Moodle/ k and I don't see any courses listed there.

Please Log in or Create an account to join the conversation.