× R0.23 No Longer Supported

[Solved] Error:joomdle plugin needs upgrading,7015

11 years 4 months ago 11 years 4 months ago by Antonio Durán.
wiz
Posts: 4
More
Topic Author
[Solved] Error:joomdle plugin needs upgrading,7015 #1
Hello,
After installing joomdle plug in, I get in notification area "Error: auth/joomdle plugin needs upgrading" and at the bottom page "Installing joomdle FAILED!".

This problem seems exactly like in: joomdle.com/index.php?option=com_kunena&...id=14&id=892&lang=en k

But, when I delete the rows from my moodle DB, the joomdle script automatically generate them again. :(

I'll thank for you help.
The topic has been locked.
11 years 4 months ago
Antonio Durán
Posts: 7311
More
[Solved] Error:joomdle plugin needs upgrading,7015 #2
Hi.

Do you get any more errors?
Do you get any message when hitting continue?

The script is meant to create the tables. That is not causing the error. I think the "plugin needs upgrading" error has to do with plugin version numbers. Which is your Moodle version?
You could try deleting the row with name=auth_joomdle_version from mdl_config table, to see if that helps.

Also: The joomdle plugin does not appear in Moodle?
The topic has been locked.
11 years 4 months ago
wiz
Posts: 4
More
Topic Author
[Solved] Error:joomdle plugin needs upgrading,7015 #3
Hi,
First, I attached the Error log from the moodle notification.

Second, I download the latest version of Moodle 1.9.8+
, the joomdle plugin does appear in moodle and deleting the auth_joomdle... table unfortunately didn't help.

Wiz

File Attachment:

File Name: Error.txt
File Size:13 KB
Attachments:
The topic has been locked.
11 years 4 months ago
Antonio Durán
Posts: 7311
More
[Solved] Error:joomdle plugin needs upgrading,7015 #4
I see you are getting all the DB errors.

You should delete all rows that give errors and the dummytable, as you said before, and see what you get when you visit Notifications again.
The topic has been locked.
11 years 4 months ago
wiz
Posts: 4
More
Topic Author
[Solved] Error:joomdle plugin needs upgrading,7015 #5
Hi,
I did it as you told in other post. But everytime I delete it the script generate them again, after pressing the "continue button" at notifcation area.
I also reinstall Joomdle plugin and Moodle again, but the problem still continued. :(

It should be mentioned, that after deleting some rows the Number of error decrease, but as I said they all start to shown again.
The topic has been locked.
11 years 4 months ago
wiz
Posts: 4
More
Topic Author
[Solved] Error:joomdle plugin needs upgrading,7015 #6
SOLVED!

In order to fix this problem. You should delete in one time all the rows with error. And just then enter the Joomdle notification area.
If you delete it all, you will probably get "Joodle Install Success". ;)
The topic has been locked.