× R0.30 Support

[Closed] Getting the 404 on Login/logout

9 years 11 months ago 9 years 9 months ago by Chris.
Clyde Williamson
Posts: 10
More
Topic Author
[Closed] Getting the 404 on Login/logout #1
I've noticed that other people have had this issue on previous builds but I didn't want to add the code/hacks until I verified that they would work with .30.

Basically, everything goes well until I enable the Joomdlehooks plugin. At that point redirects from land.php and the land logout page redirect to 404. This system is using Community Builder, Joomla and Moodle at their latest versions. The community builder plugin is installed and the Moodle mods are installed.

Everything checks out on the System Check, but the login still fails in the redirect.

Login URL:
www.mindinmotion-online.com/moodle/auth/...B9%94%B9%8D%BD%B4%BC k

Logout URL:
www.mindinmotion-online.com/moodle/auth/joomdle/land_logout.php k

Both give 404 errors.

If I disable the joomdlehooks plugin this issue goes away, but obviously the component doesn't work.

Have I misconfigured something, or do I need to apply the land.php hack from .25?
The topic has been locked.
9 years 11 months ago
Antonio Durán
Posts: 7169
More
[Closed] Getting the 404 on Login/logout #2
Hi,

not sure what hacks you refer to. I have installed R0.3 on a number of sites, without experiencing your problem.

Just to rule out CB, although I think this is not related: can you test login in with normal joomla login module and see if that changes anything?

Also, if you reload the page when you get 404, does it redirects ok?
The topic has been locked.
9 years 11 months ago
Clyde Williamson
Posts: 10
More
Topic Author
[Closed] Getting the 404 on Login/logout #3
Reloading the page works and the user is either logged in or logged out appropriately. The 'hack' I mention was in an earlier thread as it seems to mirror this earlier issue from July.

www.joomdle.com/en/forum/17-r024-support...400-bad-request#2088 k
The topic has been locked.
9 years 11 months ago
Antonio Durán
Posts: 7169
More
[Closed] Getting the 404 on Login/logout #4
Ok.

Then try with normal login module, instead of CB one, to know if it is related.
The topic has been locked.
9 years 11 months ago
Clyde Williamson
Posts: 10
More
Topic Author
[Closed] Getting the 404 on Login/logout #5
It behaves the same with either module. The URL when I get the 404 is within the moodle environment... so I may have a misconfiguration somewhere on that side, though I can't quite figure out where.

The only issue that the System Check shows is that I don't have the Joomdlehooks User Plugin enabled.
The topic has been locked.
9 years 11 months ago
Chris
Posts: 2118
More
[Closed] Getting the 404 on Login/logout #6
Hi there,

Just a quick note to acknowledge your post. Antonio is out until Tuesday and this problem is a little out of my knowledge. Please wait until he returns for his response.
The topic has been locked.
9 years 11 months ago
Clyde Williamson
Posts: 10
More
Topic Author
[Closed] Getting the 404 on Login/logout #7
No worries! Thanks for the note!
The topic has been locked.
9 years 11 months ago
Marvin L Tedder Jr
Posts: 2
More
[Closed] Getting the 404 on Login/logout #8
Hi: I am a newbie: I am having almost the same problem. I installed Joomdle .3 yesterday. Everything went well and the program seems to work well.
My problem : When someone logins on the front end.As soon as the login button is pushed I get a 404 error. A refresh of the page back to the front end and it shows I am logged in and from that point on everything appears to work fine. Logg out has no problem.

JuMar Training & Consulting Site infro.
10/12/10
Domain: www.fastdomain.com k
Joomla 1.5.21
System: •PHP Built on•: Linux fast25.fastdomain.com 2.6.28-10.45.intel.E1000E.BHsmp #1 SMP Tue Sep 21 18:34:05 MDT 2010 x86_64 •Database Version•: 5.1.47-community-log •Database Collation•: utf8_general_ci •PHP Version•: 5.2.14 •Web Server•: Apache •Web Server to PHP interface•: cgi-fcgi •Joomla! Version•: Joomla! 1.5.21 Stable [ senu takaa ama wepulai ] 08-October-2010 18:00 GMT •User Agent•: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
PHP Version 5.2.14


Moodle 1.9.9 (Build: 20100609)

Joomdle .30

Thanks for any help.
The topic has been locked.
9 years 11 months ago
Antonio Durán
Posts: 7169
More
[Closed] Getting the 404 on Login/logout #9
I am sorry, but I can think of anything else from here now,as I deployed Joomdle many times for our clients, and never experienced this problem.
The topic has been locked.
9 years 11 months ago
Marvin L Tedder Jr
Posts: 2
More
[Closed] Getting the 404 on Login/logout #10
Guys , I solved my redirect problem at login .I went to modules and enabled "LOGIN FORM" Everything is working fine Now.This is really a great product. Thank you for your hard work.!!
The topic has been locked.