Joomla URL seems to be misconfigured in Joomdle auth plugin

6 years 6 months ago
Antonio Durán
Posts: 7252
More
Joomla URL seems to be misconfigured in Joomdle auth plugin #11
wget tests are fine. However, if you get an error 500, you should have something in the logs telling you where that comes from.

Please Log in or Create an account to join the conversation.

6 years 6 months ago 6 years 6 months ago by Luke. Reason: Spelling
Luke
Posts: 11
More
Topic Author
Joomla URL seems to be misconfigured in Joomdle auth plugin #12
Hi Antonio

From post 6 I realized that the error 500 was due to me using the j2.5 url. Once I was using the correct url for j1.5 it appears that I am getting the correct response. Everything works except for user data being synced. The SSO and sessions are all fine it is simply the Moodle profile fields which are not getting populated (except for the username from joomla).

Regards

Please Log in or Create an account to join the conversation.

6 years 6 months ago
Antonio Durán
Posts: 7252
More
Joomla URL seems to be misconfigured in Joomdle auth plugin #13
Sorry, I missed that.

Data is not synced because Moodle to Joomla connection does not work. At this point I would try using a traffic inspection tool if you can run in on the server, or debug the connection code directly.
I cannot think of any more advice I can give you from here.
Also, J1.5 is quite old, so it is been a long time since I worked on a J1.5 site. There might be other possible issues I don'r remember.

Please Log in or Create an account to join the conversation.