[Solved]URL seems to be misconfigured in Joomdle auth plugin

8 years 4 months ago 8 years 4 months ago by Chris.
Canicallyoubob
Posts: 8
More
Topic Author
[Solved]URL seems to be misconfigured in Joomdle auth plugin #1
I'm getting this error and can't get a rid of it. :( Seen many posts like this in this forum and read them all (?), but nothing seems to work for me.

I'm using:
Moodle 1.9.19+ (Build: 20120831) (can't upgrade to 2.x because my host is using php version 5.2.17)
Joomla! 2.5.4
Joomdle 0.82

I'm getting the error "Joomla URL seems to be misconfigured in Joomdle auth plugin in Moodle" every time when doing system check in Joomdle (everything else is fine/"green"). Fresh install and i didn't install any Joomla extension after Moodle/Joomdle.

I was following this -
www.joomdle.com/wiki/Installing_Joomdle_in_Moodle k
- guide when installing Joomdle. My site's URL is socius.planet.ee k (Moodle is running in the same site in socius.planet.ee/moodle k) and that's written after "joomla url". Everything went smooth except one little detail - after saving Joomdle's authentication plugin settings i went to Site Administration -> Notifications and nothing happened, no script was run (there were just a warning about enabling the display_errors and suggestion to register my site). Could this be a problem?

Also i found a suggestion here -
www.joomdle.com/wiki/System_health_check k
- to "Check Joomla multi-language configuration and enter appropiate parameters in Moodle side if necessary". I've english and estonian language packs installed in both Moodle and Joomla. Could this be a problem? What parameters i've to check in Moodle?

Thank you in advance!

Please Log in or Create an account to join the conversation.

8 years 4 months ago
eukeni urgoiti
Posts: 2
More
[Solved]URL seems to be misconfigured in Joomdle auth plugin #2
I've been struggling the same issue for a couple of days and, finally, (gods must know how) I hit the bull's eye: language configuration.
The thing is I have a multilingual joomla and joomla's default language needs to be set in moodle too: Administation>Plugins>Authentication>Joomdle and set Joomla's default language same as Joomla instalation, for example en (not en-EN) for English
Hope this lucky find saves some headache.

Please Log in or Create an account to join the conversation.

8 years 4 months ago
Canicallyoubob
Posts: 8
More
Topic Author
[Solved]URL seems to be misconfigured in Joomdle auth plugin #3
Thanks, eukeni!

Well, i have two language packs - English and non-English (Estonian) - installed both in Joomla and in Moodle. I'm not using Joomla's multilanguage functionality (i.e. Joomla's plugin System - Languagefilter is disabled).

I'm using Moodle version 1.9.19 and there's no such option as Plugins under Site Administration, i can change Moodle's default language from here - Site Administration --> Language --> Language settings.

1) When I set Moodle's default language as English (en) and Joomla's default language as English (United Kingdom) I get this error - "Joomla URL seems to be misconfigured in Joomdle auth plugin in Moodle"
2) When I set Moodle's default language as Eesti (et) (Estonian) and Joomla's default language as Estonian I get this error - "Joomla URL seems to be misconfigured in Joomdle auth plugin in Moodle" - as well.

So I'm happy for you, but it doesn't seem to help me out. :(

Or maybe I misunderstood something?

Please Log in or Create an account to join the conversation.

8 years 4 months ago
eukeni urgoiti
Posts: 2
More
[Solved]URL seems to be misconfigured in Joomdle auth plugin #4
This is how i configured Moodle 2.0.10:



Attachments:

Please Log in or Create an account to join the conversation.

8 years 4 months ago 8 years 4 months ago by Canicallyoubob.
Canicallyoubob
Posts: 8
More
Topic Author
[Solved]URL seems to be misconfigured in Joomdle auth plugin #5
Well, I wrote an "angry" email to my ISP and they upgraded my php to version 5.3.5 so I was finally able to upgrade my Moodle to version 2.3. Got the same error ("Joomla URL seems to be misconfigured in Joomdle auth plugin") again when doing system check in Joomdle, then followed your advice and put "ee" (Estonian is my Joomla's default language) after "joomla default language" in Joomdle's authentication plugin in Moodle. Joomdle Web Services are ok/"green" after that! Thanks (you really saved some headache for me)! :)

But there was no such option back in 1.9, so I think, that Moodle 1.9 and multilingual Joomla users are "doomed" if they have that "Joomla URL seems to be misconfigured in Joomdle auth plugin" error. :(

e: Problem is solved for me, so mods can close this topic if they want.

Please Log in or Create an account to join the conversation.

8 years 4 months ago
Chris
Posts: 2118
More
[Solved]URL seems to be misconfigured in Joomdle auth plugin #6
Thanks for the feedback re your resolution. There will naturally be some differences in the way Moodle 1.9 and Moodle 2+ operate and sometimes if can be quite difficult to track given the vast differences in server configurations. That said, the main thing is you are up and running ... have fun

Chris

Please Log in or Create an account to join the conversation.

8 years 3 months ago 8 years 3 months ago by Héctor.
Héctor
Posts: 11
More
[Solved]URL seems to be misconfigured in Joomdle auth plugin #7
Maybe this can be save some time to somoene still using moodle 1.9.

I had the same problem described on this topic. I'm using a multilingual joomla 2.5 site (spanish-english and soon portuguese). I had joomdle 0.8 up and running before I started working on the multilingual features. After I had set that, account sync between moodle and joomdle started to fail. I also had the red cross in the Joomdle System Check, for Joomdle Web Services.

What I did is the following: Enter the joomla multi-lingual filter plugin configuration and disable the languague code in the SEF urls rewriting.

In Joomla, go to Extensions>Plug-in Manager. Find the System - Language Filter plug-in and enter it's configuration. Find the Remove URL Language Code option and set it to Yes.

I also set the Language Selection for new visitors to the site default language, but I dont think this is absolutely needed.

Regards,
Héctor

Please Log in or Create an account to join the conversation.

6 years 11 months ago
leonora
Posts: 13
More
[Solved]URL seems to be misconfigured in Joomdle auth plugin #8
Thanks for these posts! I had the same problem and I solved it with your responses.
Leonora

Please Log in or Create an account to join the conversation.